ZOJ3778--一道水题

Description

As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of the cooking, Coach Gao can choose at most M different dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 40000). The second line contains N integers Ai (1 <= Ai <= 40000).

Output

For each test case, output the least time (in minute) to finish all dishes.

Sample Input

2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10

Sample Output

3
10
解:这道题的大概意思是有个厨师给晚餐准备n个菜,每个菜有几个步骤,煮菜的每分钟,厨师能够最多同时煮m个菜,完成选择菜的一步,(在一分钟哦)
这里求的是做菜的最短时间是多少。
我们想想如果m>n,那么他可以同时做所有菜的步骤,最短时间肯定是煮最长的那个菜的时间,如果m<n,那么我们可以这样想,厨师每分钟都同时煮m个菜,那么总的步奏需要多少次,也就是多少分钟了,那我们算出总步骤除以M,如果这个数比最多那个步骤小,就说明结果肯定是最多步骤那道菜,如果比最多那个步骤大,那就是这个数。
#include<iostream>
#include<string>
using namespace std;
int main(){
    int a,n,m;
    cin>>a;
    while(a--){
        cin>>n>>m;
        int p=n;
        int maxn=0;
        int b[40000];
        int sum=0;
        for(p=n;p>0;p--){
            cin>>b[p];
            sum=sum+b[p];
            if (maxn<b[p])
            {maxn =b[p];}
        }
        if(m>=n){cout<<maxn<<endl;}
        else
        {p=sum/m;
        if (sum%m>0)
        {p=p+1;}
        if (p<maxn){cout<<maxn<<endl;}
        else {cout<<p<<endl;}
    
        }
    }
    return 0;
}
View Code

这里还要注意,如果不能整除呢,就还需要加一分钟,其实我不懂的就是,这里。记下吧

原文地址:https://www.cnblogs.com/lqs-zsjky/p/4427350.html