1125 Chain the Ropes (25分)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 1.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15
 

Sample Output:

14

考察贪心,贪心思想:我们最先进去的绳子,会切割次数最多,所以我们先对绳子长度排序,最后进行加入最长的绳子。

我们要注意精度问题,使用double存储绳子长度

#include <iostream>
#include <algorithm>
using namespace std;
int N, arr[11000];
int main() {
    scanf("%d", &N);
    for(int i = 0; i < N; i++)
        scanf("%d", &arr[i]);
    sort(arr, arr + N);
    double ans = arr[0];
    for(int i = 1; i < N; i++)
        ans = ((ans + arr[i]) / 2);
    printf("%d", (int)ans);
    return 0;
}
原文地址:https://www.cnblogs.com/littlepage/p/12837102.html