POJ 3020 Antenna Placement(二分最大匹配)

Antenna Placement

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 4316

 

Accepted: 2129

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 


Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

Source

Svenskt Mästerskap i Programmering/Norgesmesterskapet 2001

解题报告:题意就是建一个通信网络,相邻的两个站点用一个天线,求最少需要多少天线。二分图的最大匹配问题,两点之间建立关系,得到结果除以2,再用总的站点减去即可;

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 505;
//match[]作用标记,与Y部集关联的X部集的顶点编号
//visit[]在每次增广时标记部集Y中的点是否已经在匹配中
int visit[N], match[N], map[N][N];
int n, m, ans, count;
struct node
{
int id;
char c;
}str[55][55];
int move[4][2] = {{0, 1}, {1, 0}, {-1, 0}, {0, -1}};
void Judge()
{
int i, j, k, x, y;
for (i = 0; i < n; ++i)
{
for (j = 0; j < m; ++j)
{
if (str[i][j].c == '*')
{
for (k = 0; k < 4; ++k)
{
x = i + move[k][0];
y = j + move[k][1];
if (x >= 0 && x < n && y >= 0 && y < m && str[x][y].c == '*')
{
map[str[i][j].id][str[x][y].id] = 1;
}
}
}
}
}

}
int Find(int p)//寻找交替路径
{
int i;
for (i = 1; i <= n * m; ++i)
{
if (!visit[i] && map[p][i])
{
visit[i] = 1;
if (!match[i] || Find(match[i]))
{
match[i] = p;//路径取反操作
return 1;
}
}
}
return 0;
}
int main()
{
int t, i, j;
scanf("%d", &t);
while (t --)
{
scanf("%d%d", &n, &m);
memset(str, 0, sizeof(str));
memset(map, 0, sizeof(map));
memset(match, 0, sizeof(match));
count = 0;
for (i = 0; i < n; ++i)
{
getchar();
for (j = 0; j < m; ++j)
{
scanf("%c", &str[i][j].c);
if (str[i][j].c == '*')
{
count ++;//记录总点数
str[i][j].id = count;
}
}
}
Judge();
ans = 0;
for (i = 0; i <= n * m; ++i)//寻找最大匹配数
{
memset(visit, 0, sizeof(visit));
if (Find(i))
{
ans ++;
}
}
printf("%d\n", count - ans / 2);
}
return 0;
}



原文地址:https://www.cnblogs.com/lidaojian/p/2414212.html