poj_1564Sum It Up

Sum It Up
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5197   Accepted: 2613

Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25
c++提交WA,g++,accept

#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
#pragma warning(disable : 4996)
#define MAX 15
int num[MAX];
bool vis[MAX];
int t, n;
bool flag;
vector<int>ans;

void dfs(int now, int index)
{
	if(now == t)
	{
		for(int j = 0; j < n; j++)
		{
			if(vis[j])
			{
				ans.push_back(num[j]);
			}
		}
		if(ans.size() == 1)
		{
			cout << ans[0] << endl;
			flag = true;
			ans.clear();
		}
		else
		{
			for(int j = 0; j < ans.size() - 1; j++)
			{
				cout << ans[j] << "+";
			}
			cout << ans[ans.size()-1] << endl;
			flag = true;
			ans.clear();
		}
	}
	for(int i = index; i < n; i++)
	{
		if(vis[i] || (!vis[i-1] && num[i] == num[i-1]))
			continue;
		if(now + num[i] == t)
		{
			vis[i] = true;
			dfs(now + num[i], index);
			vis[i] = false;
		}
		else if(now + num[i] < t)
		{
			vis[i] = true;
			dfs(now + num[i], i + 1);
			vis[i] = false;
		}
	}
}

int main()
{
	freopen("in.txt", "r", stdin);
	while(cin >> t >> n)
	{
		if(n == 0) break;
		for(int i = 0; i < n; i++)
		{
			cin >> num[i];
		}
		cout << "Sums of " << t << ":\n";
		memset(vis, false, sizeof(vis));
		ans.clear();
		flag = false;
		dfs(0, 0);
		if(!flag)
		{
			cout << "NONE" << endl;
		}
	}
	return 0;
}




原文地址:https://www.cnblogs.com/lgh1992314/p/5835118.html