hdoj_1800Flying to the Mars

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7676    Accepted Submission(s): 2478


Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
 

Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
1 2

搜索的Trie 的题目,可是还是不会啊=。=

看完题的思路是求有多少个最长上升子序列,始终超时。

discuss说求相等的最大个数,所以map就可以很轻松的AC了。

超时代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#include<string>
#include<queue>
using namespace std;
#pragma warning(disable : 4996)
const int MAX = 3005;
int dp[MAX], num[MAX];
bool visited[MAX];
int ans;

void LIS(int *arr, int n)
{
	int len = -1;
	for (int i = 1; i <= n; i++)
	{
		dp[i] = 0;
	}
	for(int i = 1; i <= n; i++)
	{
		dp[i] = 1;
		for(int j = 1; j < i; j++)
		{
			if(arr[i] > arr[j] && dp[j] + 1 > dp[i])
				dp[i] = dp[j] + 1;
		}
		if(dp[i] > len)
		{
			len = dp[i];
		}
	}
	for (int i = 1; i <= n; i++)
	{
		visited[i] = false;
	}
	int x = 1;
	for (int i = 1; i <= n; i++)
	{
		if(dp[i] == x)
		{
			visited[i] = true;
			x++;
		}
		if(x == len + 1)
		{
			break;
		}
	}
	int index = 1;
	for (int i = 1; i <= n; i++)
	{
		if(!visited[i])
		{
			num[index++] = arr[i];
		}
	}
	if (index == 1)
	{
		return;
	}
	else
	{
		ans++;
		LIS(num, index - 1);
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	int array[MAX] ={0};
	while (scanf("%d", &n) != EOF)
	{
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &array[i]);
		}
		sort(array + 1, array + n + 1);
		ans = 1;
		LIS(array, n);
		printf("%d\n", ans);
	}
	return 0;
}
map:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include <cstdio>
using namespace std;
int main()
{
	int n,i,j,maxnum;
	while(scanf("%d",&n)==1)
	{
		maxnum=-1;
		map<int,int>Map;
		for(i=0;i<n;i++)
		{
			scanf("%d",&j);
			Map[j]++;
			if(Map[j]>maxnum)
				maxnum=Map[j];
		}
		printf("%d\n",maxnum);
	}
	return 0;
}

Trie

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<cmath>
#include<vector>
#include<algorithm>
#include<set>
#include<string>
#include<queue>
#include <stack>
using namespace std;
#pragma warning(disable : 4996)
#define MAX 10

typedef struct Node
{
	struct Node *next[MAX];
	int v;
}Node, *Trie;
Trie root;
int ans;

void init()
{
	root = (Trie)malloc(sizeof(Node));
	root->v = 0;
	for (int i = 0; i < MAX; i++)
	{
		root->next[i] = NULL;
	}
	ans = 0;
}

void createTrie(char *str)
{
	int len, i, j;
	Node *current, *newnode;
	len = strlen(str);
	if(len == 0)
	{
		return;
	}
	current = root;
	j = 0;
	while (str[j] == '0' && j < len - 1)
	{
		j++;
	}
	for(i = j; i < len; i++)
	{
		int id = str[i] - '0';
		if(current->next[id] == NULL)
		{
			newnode = (Node *)malloc(sizeof(Node));
			newnode->v = 0;
			for(j = 0; j < MAX; j++)  
			{  
				newnode->next[j] = NULL;  
			}  
			current->next[id] = newnode;
			current = current->next[id];
		}
		else
		{
			current = current->next[id];
		}
	}
	current->v++;
	if(current->v > ans)
	{
		ans = current->v;
	}
}


void dealTrie(Trie T)
{
	for(int i = 0; i < MAX; i++)
	{
		if(T->next[i] != NULL)
		{
			dealTrie(T->next[i]);
		}
	}
	free(T);
}


int main()
{
	freopen("in.txt", "r", stdin);
	int n;
	char str[35] = {0};
	while (scanf("%d", &n) != EOF)
	{
		init();
		while (n--)
		{
			scanf("%s", str);
			createTrie(str);
		}
		printf("%d\n", ans);
		dealTrie(root);
	}
	return 0;
}





原文地址:https://www.cnblogs.com/lgh1992314/p/5835054.html