zoj_3367Connect them

Connect them

Time Limit: 1 Second      Memory Limit: 32768 KB

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these nlines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cjicii = 0, 1 <= ij <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1

Hints:
A solution A is a line of p integers: a1a2, ...ap.
Another solution B different from A is a line of q integers: b1b2, ...bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= pr <= q) such that ai = bi for all 0 < i < r and ar < br 
OR
(2) p < q and ai = bi for all 0 < i <= p

新学到的,按照字典序输出最小生成树
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;
#pragma warning(disable : 4996)
#define MAX 100000
typedef struct edge
{
	int x, y;
	int w;
}edge;

edge e[MAX], path[MAX];
int father[MAX], ranks[MAX];

bool cmp1(edge a,edge b)
{
	if(a.w != b.w)
	{
		return a.w < b.w;
	}
	else if(a.x != b.x)
	{
		return a.x < b.x;
	}
	else
	{
		return a.y < b.y;
	}
}

bool cmp2(edge a, edge b)
{
	if(a.x != b.x)
	{
		return a.x < b.x;
	}
	else
	{
		return a.y < b.y;
	}
}

void Make_Set(int n)
{
	for(int i = 1; i <= n; i++)
	{
		father[i] = i;
		ranks[i] = 0;
	}
}

int Find_Set(int x)
{
	if(x != father[x])
		father[x] = Find_Set(father[x]);
	return father[x];
}

void Merge_Set(int x, int y)
{
	x = Find_Set(x);
	y = Find_Set(y);
	if(x == y) return;
	if(ranks[x] > ranks[y])
	{
		father[y] = x;
	}
	else if(ranks[x] < ranks[y])
	{
		father[x] = y;
	}
	else 
	{
		ranks[y]++;
		father[x] = y;
	}
}

int main()
{
	freopen("in.txt", "r", stdin);
	int t, n, value, count, x, y, cnt;
	scanf("%d", &t);
	while (t--)
	{
		count = 0;
		scanf("%d", &n);
		Make_Set(n);
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				scanf("%d", &value);
				if(i == j || value == 0)
				{
					continue;
				}
				e[count].x = i;
				e[count].y = j;
				e[count++].w = value;
			}	
		}
		sort(e, e + count, cmp1);
		cnt = 0;
		for (int i = 0; i < count; i++)
		{
			x = Find_Set(e[i].x);
			y = Find_Set(e[i].y);
			if(x != y)
			{
				path[cnt++] = e[i];
				Merge_Set(x, y);
			}
		}
		if(cnt != n - 1)
		{
			printf("-1\n");
		}
		else
		{
			sort(path, path + cnt, cmp2);
			for (int i = 0; i < cnt - 1; i++)
			{
				printf("%d %d ", path[i].x, path[i].y);
			}
			printf("%d %d\n", path[cnt-1].x, path[cnt-1].y);
		}
	}
	return 0;
}



原文地址:https://www.cnblogs.com/lgh1992314/p/5834983.html