HDU 4278 Faulty Odometer 第37届ACM/ICPC天津赛区网络赛1001题 (简单水题)

Faulty Odometer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 312    Accepted Submission(s): 228


Problem Description
  You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).
 
Input
  Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.
 
Output
  Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.
 
Sample Input
15 2005 250 1500 999999 0
 
Sample Output
15: 12 2005: 1028 250: 160 1500: 768 999999: 262143
 
Source
 
Recommend
liuyiding
 
 
 
简单的水题。。确实是太水了。。。
作为网络赛的第一题,一分钟就被人秒过了~~~~
以后要提高自己迅速发现水题,并迅速AC的能力。
 
此题太简单就不多说了。
简单的八进制转10进制。
#include<stdio.h>
int a[20];
int cnt;
void cc(int n)
{
    cnt=0;
    while(n)
    {
        a[cnt++]=n%10;
        n/=10;
    }
    for(int i=0;i<cnt;i++)
    {
        if(a[i]>=9)a[i]-=2;
        else if(a[i]>=4)a[i]-=1;
    }
}
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        cc(n);
        int ans=0;
        for(int i=cnt-1;i>=0;i--)
        {
            ans*=8;
            ans+=a[i];
        }
        printf("%d: %d\n",n,ans);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/kuangbin/p/2678774.html