洛谷 P1546 最短网络 Agri-Net

最短网络Agri-Net
【问题描述】
  农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了用最小的消费,他想铺设最短的光纤去连接所有的农场。你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。每两个农场间的距离不会超过100000。
【输入格式】
第一行: 农场的个数,N3<=N<=100)。
第二行.. 后来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们限制在80个字符,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为不会有线路从第i个农场到它本身。
【输出格式】
    只有一个输出,其中包含连接到每个农场的光纤的最小长度。
【输入样例】agrinet.in
    4
    0  4  9  21
    4  0  8  17
    9  8  0  16
    21 17 16  0
【输出样例】agrinet.out
  28
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>

using namespace std;

struct Tree
{
    int from,to;
    int quan;
};
Tree map[9901];

int father[101];
int n,x,k,m,tot;

int find(int l)
{
    if(father[l]!=l)
        father[l]=find(father[l]);
    return father[l];
}

void unionn(int r1,int r2)
{
    int r3=find(r1);
    int r4=find(r2);
    if(r3!=r4)
        father[r3]=r4;
}

bool cmp(const Tree &a,const Tree &b)
{
    if(a.quan < b.quan)    return 1;
    return 0;
}

int main()
{
    ios::sync_with_stdio(false);
    cin>>n;
    for(int i=1;i<=n;i++)
        father[i]=i;
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
        {
            cin>>x;
            if(x!=0)
            {
                m++;
                map[m].from = i;
                map[m].to =j;
                map[m].quan =x;    
            }
        }
    }
    sort(map+1,map+m+1,cmp);
    for(int i=1;i<=m;i++)
    {
        if(find(map[i].from)!=find(map[i].to))
        {
            unionn(map[i].from,map[i].to);
            tot+=map[i].quan;
            k++;
        }
        if(k == n-1)    break;
    }
    cout<<tot;
    return 0;
}
/*
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
*/
原文地址:https://www.cnblogs.com/kuaileyongheng/p/6705610.html