POJ 1125 Stockbroker Grapevine

Stockbroker Grapevine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 23783   Accepted: 13067

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

题意:有1条谣言,n个证券经理,每个经理可以向其他人转播谣言,(每个经理的传播数任意)。而每个经理和其他经理传播时,需要时间(如a对b传播需要3,a对c传播需要4)。问从哪个经理作为起点,能够传播的人数最多,并且时间最短。


其实这道题比较像是多点对之间的最短路,(首先要满足传播的人数最多,其次要满足在所有最短路当中的最大值最小。。好绕口)

那我采用了Floyd来算多源最短路,之后再找到起点和最短时间

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#define maxn 105
#define INF 1000000
using namespace std;
int n,map[maxn][maxn];
void init()
{
    int i,j;
    for (i=1; i<=n; i++)
    {
        for (j=1; j<=n; j++)
            map[i][j]=INF;
        map[i][i]=0;
    }
    for (i=1; i<=n; i++)
    {
        int t,a,b;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d",&a,&b);
            map[i][a]=b;
        }
    }
}
void floyd()
{
    int i,j,k;
    for (k=1; k<=n; k++)
        for (i=1; i<=n; i++)
            for (j=1; j<=n; j++)
                if (map[i][k]+map[k][j]<map[i][j])
                    map[i][j]=map[i][k]+map[k][j];
    k=0;
    int m=0,z=INF;
    /*
    for (i=1; i<=n; i++){
        for (j=1; j<=n; j++)
            cout<<map[i][j]<<" ";
        cout<<endl;
    }
    */
    for(i=1; i<=n; i++)
    {
        int p=0,t=0;
        for (j=1; j<=n; j++)
            if (map[i][j]!=INF)
            {
                if (map[i][j]>t) t=map[i][j];//用t来记录以每个经纪人为起点,传播的最长时间
                p++;//p来记录每个经纪人可以传多少其他人
            }
        if (p>m)//人数是第一个条件,所以人数大,就进行交换
        {
            m=p;
            k=i;
            z=t;
        }
        else if (p==m && t<z)//如果人数相同,就比较最长时间,取较短的
        {
            m=p;
            k=i;
            z=t;

        }
    }
    cout<<k<<" "<<z<<endl;
}
int main ()
{
    while(cin>>n)
    {
        if (n==0) break;
        init();
        floyd();
    }
    return 0;
}


原文地址:https://www.cnblogs.com/keanuyaoo/p/3278163.html