Power Strings

Total Submission(s) : 10 Accepted Submission(s) : 4
Problem Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
 
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
 
Output
For each s you should print the largest n such that s = a^n for some string a.
 
Sample Input
abcd aaaa ababab .
 
Sample Output
1 4 3
#include<iostream>
#include<string.h>
using namespace std;
int next[1000005],len;
void set_naxt(char str[])
{
    int i=0,j=-1;
    next[0]=-1;
    len=strlen(str);
    while(i<len)
    {
        if(j==-1||str[i]==str[j])
        {
            i++; j++;
            next[i]=j;
        }
        else
        j=next[j];
    }
}
int main()
{
    int I;
    char str[1000001];
    while(cin>>str&&strcmp(str,".")!=0)
    {
        set_naxt(str);
        if(len%(len-next[len])==0)
        I=len/(len-next[len]);
        else
        I=1;
        cout<<I<<endl;
    }
}
/*len=strlen(str);
        for(i=1;i<=len;i++)
        {
            for(j=i;j<len;j++)
            if(str[j]!=str[j%i])
            break;
            if(j==len)
            break;
        }
*/


原文地址:https://www.cnblogs.com/jiangu66/p/3220308.html