POJ2823:Sliding Window(单调队列||线段树) java程序员

Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 28126   Accepted: 8389
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

MYCode(线段树版本)
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define MAX 1000010
struct node
{
    int lt;
    int rt;
    int mini;
    int most;
}a[4*MAX];
int v[MAX];
int lt[MAX];
int rt[MAX];
int min(int a,int b){return a<b?a:b;}
int max(int a,int b){return a>b?a:b;}
void build(int s,int t,int step)
{
    a[step].lt=s;
    a[step].rt=t;
    if(s==t)
    {
        a[step].mini=a[step].most=v[s];
        return;
    }
    int mid=(a[step].lt+a[step].rt)/2;
    build(s,mid,2*step);
    build(mid+1,t,2*step+1);
    a[step].mini=min(a[2*step].mini,a[2*step+1].mini);
    a[step].most=max(a[2*step].most,a[2*step+1].most);
}
node query(int s,int t,int step)
{
    if(s==a[step].lt&&t==a[step].rt)
    {
        return a[step];
    }
    if(a[step].lt==a[step].rt)return a[step];
    int mid=(a[step].lt+a[step].rt)/2;
    if(mid>=t)
    return query(s,t,2*step);
    else if(mid<s)
    return query(s,t,2*step+1);
    else
    {
        node tp1=query(s,mid,2*step);
        node tp2=query(mid+1,t,2*step+1);
        node tp;
        tp.lt=s;
        tp.rt=t;
        tp.mini=min(tp1.mini,tp2.mini);
        tp.most=max(tp1.most,tp2.most);
        return tp;
    }
}
int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k) != EOF)
    {
        int i;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&v[i]);
        }
        build(1,n,1);
        int ct=0;
        for(i=1;i<=n-k+1;i++)
        {
            node ans=query(i,i+k-1,1);
            lt[ct]=ans.mini;
            rt[ct]=ans.most;
            ct++;
        }
        for(i=0;i<ct;i++)
        {
            printf("%d",lt[i]);
            if(i!=ct-1)
            printf(" ");
        }
        printf("\n");
        for(i=0;i<ct;i++)
        {
            printf("%d",rt[i]);
            if(i!=ct-1)
            printf(" ");
        }
        printf("\n");
    }
}
MYCode:(单调队列版本)
 
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define MAX 1000010
int v[MAX];
int lt[MAX];
int rt[MAX];
int st[MAX];
int n;
int k;
void solve1()
{
    int head=0,tail=0;
    int ct=0;
    int i;
    for(i=1;i<=n;i++)
    {
        while(head<tail&&v[st[tail-1]]<v[i])tail--;
        st[tail++]=i;
        while(i-st[head]>=k)head++;
        rt[ct++]=st[head];
    }
}
void solve2()
{
    int head=0,tail=0;
    int ct=0;
    int i;
    for(i=1;i<=n;i++)
    {
        while(head<tail&&v[st[tail-1]]>v[i])tail--;
        st[tail++]=i;
        while(i-st[head]>=k)head++;
        lt[ct++]=st[head];
    }
}
int main()
{
    while(scanf("%d%d",&n,&k) != EOF)
    {
        int i;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&v[i]);
        }
        solve1();
        solve2();
        for(i=k-1;i<n;i++)
        {
            printf("%d",v[lt[i]]);
            if(i!=n-1);
            printf(" ");
        }
        printf("\n");
         for(i=k-1;i<n;i++)
        {
            printf("%d",v[rt[i]]);
            if(i!=n-1);
            printf(" ");
        }
        printf("\n");
    }
}
 
Run ID User Problem Result Memory Time Language Code Length Submit Time
11039225 ruffy 2823 Accepted 43848K 11094MS C++ 1959B 2012-11-22 15:22:12
11039159 ruffy 2823 Accepted 11940K 6735MS C++ 1208B 2012-11-22 15:00:32
线段树11094MS
单调队列6735MS
 
原文地址:https://www.cnblogs.com/java20130725/p/3215898.html