HDU 2527 Safe Or Unsafe (哈夫曼树)

Safe Or Unsafe

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 999    Accepted Submission(s): 378

Problem Description
Javac++ 一天在看计算机的书籍的时候,看到了一个有趣的东西!每一串字符都可以被编码成一些数字来储存信息,但是不同的编码方式得到的储存空间是不一样的!并且当储存空间大于一定的值的时候是不安全的!所以Javac++ 就想是否有一种方式是可以得到字符编码最小的空间值!显然这是可以的,因为书上有这一块内容--哈夫曼编码(Huffman Coding);一个字母的权值等于该字母在字符串中出现的频率。所以Javac++ 想让你帮忙,给你安全数值和一串字符串,并让你判断这个字符串是否是安全的?
 
Input
输入有多组case,首先是一个数字n表示有n组数据,然后每一组数据是有一个数值m(integer),和一串字符串没有空格只有包含小写字母组成!
 
Output
如果字符串的编码值小于等于给定的值则输出yes,否则输出no。
 
Sample Input
2
12
helloworld
66
ithinkyoucandoit
 
Sample Output
no
yes
 
Source
 
Recommend
gaojie
 
 
 
 
#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>

using namespace std;

priority_queue<int,vector<int>,greater<int> > q;
char str[100010];
int huf[26];

int main(){

    //freopen("input.txt","r",stdin);

    int t,n;
    scanf("%d",&t);
    while(t--){
        memset(huf,0,sizeof(huf));
        while(!q.empty())
            q.pop();
        scanf("%d",&n);
        scanf("%s",str);
        for(int i=0;str[i]!='\0';i++)
            huf[str[i]-'a']++;
        for(int i=0;i<26;i++)
            if(huf[i])
                q.push(huf[i]);
        if(q.size()==1){
            if(q.top()>n)
                printf("no\n");
            else
                printf("yes\n");
            continue;
        }
        int ans=0,a,b;
        while(q.size()!=1){
            a=q.top();q.pop();
            b=q.top();q.pop();
            q.push(a+b);
            ans+=(a+b);
        }
        if(ans<=n)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3011041.html