PKU 3259 Wormholes (Bellford_man 找负权环)

Wormholes

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)

Total Submission(s) : 15   Accepted Submission(s) : 10

Problem Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

 
Input
Line 1: A single integer, F. F farm descriptions follow. Line 1 of each farm: Three space-separated integers respectively: N, M, and W Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
 
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
 
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
 
Sample Output
NO
YES
 
Source
PKU
 
 

题意:

       John的农场里N块地,M条路连接两块地,W个虫洞,虫洞是一条单向路,会在你离开之前把你传送到目的地,就是当你过去的时候时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。简化下,就是看图中有没有负权环。有的话就是可以,没有的话就是不可以了。

 

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int VM=520;
const int EM=5020;
const int INF=0x3f3f3f3f;

struct Edge{
    int u,v;
    int w;
}edge[EM<<1];

int N,M,W,cnt,dis[VM];

void addedge(int cu,int cv,int cw){
    edge[cnt].u=cu;      edge[cnt].v=cv;      edge[cnt].w=cw;
    cnt++;
}

int Bellman(){
    int i,j,flag;
    for(i=0;i<N;i++)
        dis[i]=INF;
    for(i=1;i<N;i++){
        flag=1;
        for(j=0;j<cnt;j++)
            if(dis[edge[j].u]>dis[edge[j].v]+edge[j].w){
                dis[edge[j].u]=dis[edge[j].v]+edge[j].w;
                flag=0;
            }
        if(flag)
            break;
    }
    for(i=0;i<cnt;i++)
        if(dis[edge[i].u]>dis[edge[i].v]+edge[i].w)
            return 1;
    return 0;
}

int main(){

    //freopen("input.txt","r",stdin);

    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&N,&M,&W);
        cnt=0;
        int u,v,w;
        for(int i=0;i<M;i++){
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
            addedge(v,u,w);
        }
        for(int i=0;i<W;i++){
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,-w);
        }
        if(Bellman())
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}

 

 

原文地址:https://www.cnblogs.com/jackge/p/2830912.html