VF

VF

描述

Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is an amount of integers from 1 to N that have the sum of digits S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task. Can you solve the problem?
 
输入
There are multiple test cases. Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10

 
#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <memory.h>
#include <string>
#include <math.h>
using namespace std;
  int arr[9][81];
int main()
{
      int n;
              for(int i=1;i<=9;i++)
            arr[1][i] = 1;

        for(int i=1;i<=9;i++)
            for(int j=1;j<=9*i;j++)
                for(int k=0;k<=9 && k<=j;k++)
                    arr[i][j] += arr[i-1][j-k];

         while(cin>>n)
      {
          if(n==1)
          {
              cout<<10<<endl;
              continue;
          }


        int sum = 0;
        for(int i=1;i<=9;i++)
            sum += arr[i][n];
        cout<<sum<<endl;
      }
     return 0;
}

            
原文地址:https://www.cnblogs.com/imwtr/p/4069558.html