YTU 2618: B 求类中数据成员的最大值-类模板

2618: B 求类中数据成员的最大值-类模板

时间限制: 1 Sec  内存限制: 128 MB
提交: 430  解决: 300

题目描述

声明一个类模板,类模板中有三个相同类型的数据成员,有一函数来获取这三个数据成员的最大值。

类模板声明如下:

template<class numtype>

class Max

{

public:

Max(numtype a,numtype b,numtype c);

numtype getMax();

private:

numtype x,y,z;

};

请在下面的程序段基础上完成整个设计:
#include <iostream>
#include <iomanip>
using namespace std;

template<class numtype>

class Max
{

public:

Max(numtype a,numtype b,numtype c);

numtype getMax();

private:

numtype x,y,z;

};

//将程序需要的其他成份写在下面,只提交begin到end部分的代码
//******************** begin ********************


//********************* end ********************

int main()

{

int i1,i2,i3;

cin>>i1>>i2>>i3;

Max<int> max1(i1,i2,i3);

cout<<max1.getMax()<<endl;

float f1,f2,f3;

cin>>f1>>f2>>f3;

Max<float> max2(f1,f2,f3);

cout<<setiosflags(ios::fixed);

cout<<setprecision(2);

cout<<max2.getMax()<<endl;

char c1,c2,c3;

cin>>c1>>c2>>c3;

Max<char> max3(c1,c2,c3);

cout<<max3.getMax()<<endl;

return 0;

}

输入

分别输入3个整数,3个浮点数,3个字符

输出

 3个整数的最大值
3个浮点数中的最大值
3个字符中的最大值

样例输入

9 5 6
1.1 3.4 0.9
a b c

样例输出

9
3.40
c

提示

在类模板外定义各成员函数。

只提交begin到end部分的代码。


迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

#include <iostream>
#include <iomanip>
using namespace std;
template<class numtype>
class Max
{
public:
    Max(numtype a,numtype b,numtype c);
    numtype getMax();
private:
    numtype x,y,z;
};
template<class numtype>
Max<numtype>::Max(numtype a,numtype b,numtype c)
{
    x=a;
    y=b;
    z=c;
}
template<class numtype>
numtype Max<numtype>::getMax()
{
    return (x>y&&x>z)?x:(y>x&&y>z)?y:z;
}
int main()
{
    int i1,i2,i3;
    cin>>i1>>i2>>i3;
    Max<int> max1(i1,i2,i3);
    cout<<max1.getMax()<<endl;
    float f1,f2,f3;
    cin>>f1>>f2>>f3;
    Max<float> max2(f1,f2,f3);
    cout<<setiosflags(ios::fixed);
    cout<<setprecision(2);
    cout<<max2.getMax()<<endl;
    char c1,c2,c3;
    cin>>c1>>c2>>c3;
    Max<char> max3(c1,c2,c3);
    cout<<max3.getMax()<<endl;
    return 0;
}

原文地址:https://www.cnblogs.com/im0qianqian/p/5989523.html