HDU 1907 John

^^^转载请注明出处,谢谢合作O(∩_∩)O~

John

Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 
Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 
Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 
Sample Input
2 3 3 5 1 1 1
 
Sample Output
John Brother
:典型的尼姆博弈,只要判断谁先拿谁输的条件即可
#include<iostream>
using namespace std;
#define M 5000
int main()
{
    int t;
    int a[M];
    cin>>t;
    while(t--)
    {
        int i,n;
        int s=0;//存异或值
        int s1=0;//计数大于等于2的堆
        cin>>n;
        for(i=0;i<n;i++)
        {
          cin>>a[i];
          if(a[i]>=2)s1++;
          s=s^a[i];
        }
        if(s==0)
        {
            if(s1>=2)
            cout<<"Brother"<<endl;            
            else 
            cout<<"John"<<endl;    
        }
        else
        {
            if(s1>=1)
            cout<<"John"<<endl;
            else
            cout<<"Brother"<<endl;
        }
          
    }
    
    return 0;
}
 
原文地址:https://www.cnblogs.com/hsqdboke/p/2452964.html