UVa 10935

原题

Throwing cards away I
  Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:
  Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck.
Your task is to find the sequence of discarded cards and the last, remaining card.

Input Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.

Output For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.

Sample Input

7 19 10 6 0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4

Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

 

题目描述:桌上有n(n<=50)张牌,从第一张开始,从上往下依次编号为1-n。当至少还剩下两张牌时进行以下操作:把第一张牌扔掉,然后把新的第一张牌放到整叠牌的最后。输入每行包含一个n,输出每次扔掉的牌以及最后剩下的牌。

此题可以用队列的方式解题,队列是一种特殊的线性结构,只允许在队列的首部(head)进行删除,成为“出队”,而在队列的首部(tail)进行插入,称为“入队”。

队列解题思路如下:

  第一步,要将第一个数删除,先想一下怎么将数组的第一个数删除呢,最简单的方法就是将所有的数都往后挪一位,将前面的数覆盖。但是如果每次都挪一次,很耗费时间。在此题中,我们引入整型变量head和tail,head用来记录队列的第一位,tail记录最后一位的下一个位置(这里tail记录最后一位的下一个位置是因为当队列只剩下一个元素时,第一位会和最后一位重合)。每当删除一个数,head++,浪费一个空间,但可以节省很多时间,新增加一个数也是,把需要增加的数放到队尾即a【tail】之后再tail++就可以了。

注意:输出格式,当n=1时,“Discarded cards:”后没有空格。

下面是代码(已运行通过)


#include<iostream>  

using namespace std;

int s[1000]; //队列的主体,用来储存内容
 

int n;

int main()

{

       while(cin>>n&&n)

{     

              int head=1;

        int tail=n; //head为队首,tail为队尾即n
 

       for(int i=1;i<=n;i++)

   {

              s[i]=i;

       }     

        if(n==1)

{

       cout<<"Discarded cards:"<<endl<<"Remaining card: 1"<<endl;

}

else

{

       cout<<"Discarded cards: ";

       while(head<tail)

{

              cout<<s[head];head++;

       if(head<tail)

                     cout<<", ";

       if(head==tail)

                     cout<<endl<<"Remaining card: "<<s[head]<<endl;

              s[++tail]=s[head];

              head++;

             

}

}

}

return 0;

}  

 

 

原文地址:https://www.cnblogs.com/hfc-xx/p/4652647.html