找矩形(hdu2524)

/*
矩形A + B
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2570    Accepted Submission(s): 1946


Problem Description
给你一个高为n ,宽为m列的网格,计算出这个网格中有多少个矩形,下图为高为2,宽为4的网格.

 

Input
第一行输入一个t, 表示有t组数据,然后每行输入n,m,分别表示网格的高和宽 ( n < 100 , m < 100).

 

Output
每行输出网格中有多少个矩形.
 

Sample Input
2
1 2
2 4
 

Sample Output
3
30
 //我自己想出来的啊,这规律
*/
#include<iostream>
using namespace std;
int main()
{
    int ans=1,n,m,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        ans=n*(n+1)/2*m*(m+1)/2;
        printf("%d\n",ans);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/heqinghui/p/2785670.html