[HDU 1159] Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26958    Accepted Submission(s): 11994

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 
Sample Input
abcfbc abfcab programming contest abcd mnp
 
Sample Output
4 2 0
 
Source
Southeastern Europe 2003
 
没什么好说的,上代码
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define max(a,b) a>b?a:b
#define INF 0x7ffffff
#define N 1010

int dp[N][N]; //dp[i][j]表示a中前i个字符和b中前j个字符的最长公共子序列
char s1[N],s2[N];

int main()
{
    int i,j;
    while(scanf("%s%s",s1+1,s2+1)!=EOF)
    {
        int l1=strlen(s1+1);
        int l2=strlen(s2+1);
        memset(dp,0,sizeof(dp));
        for(i=1;i<=l1;i++)
        {
            for(j=1;j<=l2;j++)
            {
                if(s1[i]==s2[j])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else
                {
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        cout<<dp[l1][l2]<<endl;
    }
    return 0;
}
趁着还有梦想、将AC进行到底~~~by 452181625
原文地址:https://www.cnblogs.com/hate13/p/4050418.html