HDU 1001 Sum Problem

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

 

 

 

Input

 

The input will consist of a series of integers n, one integer per line.

 

 

 

Output

 

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

 

 

 

Sample Input

 

1 100

 

 

 

Sample Output

 

1 5050

题意:输入一个整数n,求从1到n之间各个整数之和,包括1和n。

分析:循环次数已知时用for循环更方便。

AC源代码(c语言):

#include<stdio.h>
int main()
{
 int n,i;long sum;
 while(scanf("%d",&n)!=EOF)
  {
     sum=0;
     for(i=1;i<=n;i++)
     sum+=i;
     printf("%d\n\n",sum);
  }
 return 0;
}

2013-01-13

原文地址:https://www.cnblogs.com/fjutacm/p/2858772.html