POJ 3468 A Simple Problem with Integers

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.
 
题意:区间修改与查询区间和
 
分析 
线段树的基本操作,使用lazy标记的思想。
 
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include <queue>
#include <vector>
#include<bitset>
#include<map>
#include<deque>
using namespace std;
typedef long long LL;
const int maxn = 1e5+150;
const int mod = 77200211+233;
typedef pair<int,int> pii;
#define X first
#define Y second
#define pb push_back
#define mp make_pair
#define ms(a,b) memset(a,b,sizeof(a))
const int inf = 0x3f3f3f3f;
#define lson l,m,2*rt
#define rson m+1,r,2*rt+1

LL sum[maxn<<2],lazy[maxn<<2];

struct node{
    int l,r;
    int mid(){
        return (l+r)>>1;
    }
}tree[maxn<<2];
//更新父亲信息
void PushUp(int rt){
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
//更新子孙信息
void PushDown(int rt,int len){
    if(lazy[rt]){
        lazy[rt<<1]+=lazy[rt];
        lazy[rt<<1|1]+=lazy[rt];
        sum[rt<<1] += lazy[rt]*(len-len/2);
        sum[rt<<1|1] += lazy[rt]*(len/2);
        lazy[rt]=0;
    }
}

void build(int l,int r,int rt){
    tree[rt].l=l,tree[rt].r=r;
    lazy[rt]=0;
    if(l==r){
        scanf("%lld",&sum[rt]);
        return;
    }
    int m=tree[rt].mid();
    build(lson);
    build(rson);
    PushUp(rt);
}

void update(int d,int l,int r,int rt){
    if(tree[rt].l==l&&tree[rt].r==r){
        lazy[rt] += d; //打上标记
        sum[rt] += d*(r-l+1);
        return;
    }
    if(tree[rt].l==tree[rt].r) return;

    PushDown(rt,tree[rt].r-tree[rt].l+1);
int m=tree[rt].mid(); if(r<=m) update(d,l,r,rt<<1); else if(l>m) update(d,l,r,rt<<1|1); else{ update(d,l,m,rt<<1); update(d,m+1,r,rt<<1|1); } PushUp(rt); } LL query(int l,int r,int rt){ if(tree[rt].l==l&&tree[rt].r==r){ return sum[rt]; } PushDown(rt,tree[rt].r-tree[rt].l+1); int m = tree[rt].mid(); LL res=0; if(r<=m){ res+=query(l,r,rt<<1); }else if(l>m){ res+=query(l,r,rt<<1|1); }else{ res+=query(l,m,rt<<1); res+=query(m+1,r,rt<<1|1); } return res; } int main(){ int n,m; while(~scanf("%d%d",&n,&m)){ build(1,n,1); while(m--){ char ch[2]; scanf("%s",ch); int a,b,c; if(ch[0]=='Q'){ scanf("%d%d",&a,&b); cout<<query(a,b,1)<<endl; }else{ scanf("%d%d%d",&a,&b,&c); update(c,a,b,1); } } } return 0; }
原文地址:https://www.cnblogs.com/fht-litost/p/8597969.html