The more, The Better

The more, The Better

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10373    Accepted Submission(s): 6037


Problem Description
ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物。但由于地理位置原因,有些城堡不能直接攻克,要攻克这些城堡必须先攻克其他某一个特定的城堡。你能帮ACboy算出要获得尽量多的宝物应该攻克哪M个城堡吗?
 
Input
每个测试实例首先包括2个整数,N,M.(1 <= M <= N <= 200);在接下来的N行里,每行包括2个整数,a,b. 在第 i 行,a 代表要攻克第 i 个城堡必须先攻克第 a 个城堡,如果 a = 0 则代表可以直接攻克第 i 个城堡。b 代表第 i 个城堡的宝物数量, b >= 0。当N = 0, M = 0输入结束。
 
Output
对于每个测试实例,输出一个整数,代表ACboy攻克M个城堡所获得的最多宝物的数量。
 
Sample Input
3 2 0 1 0 2 0 3 7 4 2 2 0 1 0 4 2 1 7 1 7 6 2 2 0 0
 
Sample Output
5 13
#include <bits/stdc++.h>

using namespace std;
const int maxn=266;
struct node{
      int to,nx;
}p[maxn];
int n,m,dp[maxn][maxn],tot,head[maxn];
void addedge(int u,int v){
     p[++tot].to=v,p[tot].nx=head[u],head[u]=tot;
}
void dfs(int cur){
     for(int i=head[cur];i;i=p[i].nx){
          int to=p[i].to;
          dfs(to);
          for(int j=m;j>=0;j--){
                    for(int k=1;k<=j;k++){
                        dp[cur][j]=max(dp[cur][j],dp[to][j-k]+dp[cur][k]);
                    }
          }
     }
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&n&&m){
         memset(head,0,sizeof(head));
         tot=0;
         memset(dp,0,sizeof(dp));
         for(int i=1;i<=n;i++){
             int a,b;
             scanf("%d%d",&a,&b);
             addedge(a,i),dp[i][1]=b;
         }
         m++;
         dfs(0);
         cout<<dp[0][m]<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/czy-power/p/10561740.html