POJ 3258 Wormholes解题报告

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 22311   Accepted: 7958

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

求有无负权环。

#include <iostream>
#include <cstring>
#define OO 9999999

using namespace std;

int n,m,w,F;
int a[600][600];
int dist[600];

int main()
{
    int s,e,t;
    bool flag;
    cin>>F;
    while (F--)
    {
        memset(a,0,sizeof(a));
        cin>>n>>m>>w;
        for (int i=1;i<=m;i++)
        {
            cin>>s>>e>>t;
            if (a[s][e]==0)
            {
                a[s][e]=t;
                a[e][s]=t;
            }
            else if (a[s][e]>0&&t<a[s][e])
            {
                a[s][e]=t;
                a[e][s]=t;
            }
        }
        for (int i=1;i<=w;i++)
        {
            cin>>s>>e>>t;
            a[s][e]=-t;
        }
        for (int i=0;i<=n;i++) dist[i]=OO;
        dist[1]=0;
        for (int loop=1;loop<=n;loop++)
        {
            flag=true;
            for (int i=1;i<=n;i++)
            {
                for (int j=1;j<=n;j++)
                {
                    if (a[i][j]!=0)
                    {
                        if (dist[j]>dist[i]+a[i][j])
                        {
                            dist[j]=dist[i]+a[i][j];
                            flag=false;
                        }
                    }
                }
            }
            if (flag)break;
        }
        if (flag) cout<<"NO"<<endl;
        else cout<<"YES"<<endl;
    }
    return 0;
}


原文地址:https://www.cnblogs.com/cyendra/p/3038407.html