hdu 3853 LOOPS 圆环之理 概率dp

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 830    Accepted Submission(s): 342


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
6.000
 
-------------------------

f[i][j]表示吼姆啦从(i,j)到达n,m的期望

数组a1,a2,a3,分别表示留在原地,向右走,向下走的概率。

则f[i][j]=(f[i][j]*a1[i][j]) +(f[i][j+1]*a2[i][j]) + (f[i+1][j]*a3[i][j]) + 2 移项得  f[i][j]= ( (f[i][j+1]*a2[i][j]) + (f[i+1][j]*a3[i][j]) + 2 )/(1-a1[i][j]);

注意a1[i][j]==1的情况,即吼姆啦酱陷入了无限循环中。由于吼姆啦一定会到达终点,所以直接跳过这种点不做考虑。

------------------------

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;

const double eps=1e-5;

double f[1111][1111];
double a1[1111][1111],a2[1111][1111],a3[1111][1111];
int n,m;

int main()
{
    while (~scanf("%d%d",&n,&m))
    {
        for (int i=1;i<=n;i++)
        {
            for (int j=1;j<=m;j++)
            {
                scanf("%lf%lf%lf",&a1[i][j],&a2[i][j],&a3[i][j]);
            }
        }
        f[n][m]=0;
        for (int i=n;i>=1;i--)
        {
            for (int j=m;j>=1;j--)
            {
                if (i==n&&j==m) continue;
                if (fabs(1-a1[i][j])<eps) continue;
                f[i][j]= ( (f[i][j+1]*a2[i][j]) + (f[i+1][j]*a3[i][j]) + 2 )/(1-a1[i][j]);
            }
        }
        printf("%0.3lf\n",f[1][1]);
    }
    return 0;
}








原文地址:https://www.cnblogs.com/cyendra/p/3038368.html