HDU 1114 Piggy-Bank(完全背包)

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input

3
10 110
 2
1 1
30 50
 
 
10 110
 2
1 1
50 30
 
 
1 6
 2
10 3
20 4
 

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
 
 
 题意: 有一个储钱罐为空的时候重量为E,装满东西的时候重量为F,然后输入一个N,N组数据,然后是P,W。P为钱的价值,W为钱的重量,求这个储钱罐的最小钱数。
解题思路:储钱罐装满钱的总重量-空储钱罐的重量=储钱罐可放钱的总重量。即 V=F-E;不过特殊的就是这种背包必须把背包填满,即最终放的硬币必须是刚刚好为V.01背包中已经讲了额,只需要再初始化的时候把dp[0]初始化为0,其它的初始化为负无穷即可。但是考虑到这道题目是要求最小的钱数的。
所以初始化的时候,要初始化为正无穷。
 代码如下:
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
#define INF 0x3f3f3f3f
#define MAX 1000005
int value[510],wight[510],f[MAX];
void init()
{
    memset(value,0,sizeof(value));
    memset(wight,0,sizeof(value));
    memset(f,INF,sizeof(f));   //求最小赋为极大值
}
int main()
{
    int T,E,F,N;
    int V;   //储钱罐的最大容量
    int i,j;
    cin>>T;
    while(T--)
    {
        init();
        cin>>E>>F;
        V=F-E;  //最大容量=储钱罐的总重量-空储钱罐的重量
        cin>>N;
        for(i=0; i<N; i++)
            cin>>value[i]>>wight[i];
        f[0]=0;
        for(i=0; i<N; i++)
        {
            for(j=wight[i]; j<=V; j++)
                f[j]=min(f[j],f[j-wight[i]]+value[i]);  
        }
        if(f[V]==INF)
            cout<<"This is impossible."<<endl;
        else
            cout<<"The minimum amount of money in the piggy-bank is "<<f[V]<<'.'<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/cxbky/p/4727546.html