POJ1458 Subsquence

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
题解:DP,最大公共子序列;dp[i][j]表示第一个串的第i个字符,第二个串的第j个字符所能匹配的最长公共子串。if s1[i]==s2[j] dp[i][j]=dp[i-1][j-1]+1; else dp[i][j]=max(dp[i-1][j],dp[i][j-1])找最大值即可:
参考代码为:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
using namespace std;

int main()
{
	string str1, str2;
	while (cin >> str1 >> str2)
	{
		int l1 = str1.size();
		int l2 = str2.size();
		int dp[1010][1010]={0};
		int Max = 0;

		for (int i = 0; i<l1; i++)
		{
			for (int j = 0; j<l2; j++)
			{
				if (str1[i] == str2[j])
				{
					dp[i+1][j+1] = dp[i][j] + 1;
					if (dp[i+1][j+1]>Max)
						Max = dp[i+1][j+1];

				}
				else
				{
					dp[i+1][j+1] = max(dp[i][j+1], dp[i+1][j]);
					if (dp[i + 1][j + 1]>Max)
						Max = dp[i + 1][j + 1];
				}
			}
		}
		cout << Max << endl;

	}
	return 0;
}

  

原文地址:https://www.cnblogs.com/csushl/p/9409792.html