组合数学

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5706    Accepted Submission(s): 2311


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 
Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 
Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 
Sample Input
3
1 2 4
3
9 2 1
 
Sample Output
0
2
4 5
 

Mean: 

 给你N个砝码,每个砝码有自己的重量,现在要你计算从1~S中哪些重量是不能用这些砝码称出来的。(其中S为所有砝码的重量之和)。

analyse:

 就是一道母函数的运用题,要注意的是砝码可以摆放在两个托盘上,所以要注意的是两个托盘两边的差值也能称出来的情况,其他的和普通母函数差不多。

Time complexity:O(n^3)

Source code:

// Memory   Time
// 1347K     0MS
// by : Snarl_jsb
// 2014-09-19-11.59
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<string>
#include<climits>
#include<cmath>
#define N 10100
#define LL long long
using namespace std;

int val[N];

int c1[N],c2[N];

int main()
{
    ios_base::sync_with_stdio(false);
    cin.tie(0);
//    freopen("C:\Users\ASUS\Desktop\cin.cpp","r",stdin);
//    freopen("C:\Users\ASUS\Desktop\cout.cpp","w",stdout);
    int n;
    while(cin>>n)
    {
        long long sum=0;
        for(int i=1;i<=n;++i)
        {
            cin>>val[i];
            sum+=val[i];
        }
        memset(c1,0,sizeof(c1));
        memset(c2,0,sizeof(c2));
        c1[0]=c1[val[1]]=1;
        for(int i=2;i<=n;++i)
        {
            for(int j=0;j<=sum;++j)
            {
                for(int k=0;k<=1;++k)
                {
                    c2[k*val[i]+j]+=c1[j];
                    c2[abs(k*val[i]-j)]+=c1[j];
                }
            }
            for(int j=0;j<=sum;++j)
            {
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        int res[N],ans=0;
        for(int i=1;i<=sum;++i)
        {
            if(!c1[i])
            {
                res[ans++]=i;
            }
        }
        if(!ans)
        {
            puts("0");
            continue;
        }
        cout<<ans<<endl;
        ans--;
        for(int i=0;i<ans;++i)
        {
            cout<<res[i]<<" ";
        }
        cout<<res[ans]<<endl;
    }
    return 0;
}

  

原文地址:https://www.cnblogs.com/crazyacking/p/3982043.html