天梯赛 L2-006 树的遍历 (二叉树)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7

2 3 1 5 7 6 4

1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

分析:

我们应该知道可以由一棵二叉树的中序序列和后序序列,或则中序序列和先序序列来唯一的确定一棵二叉树。

因为后续序列的遍历顺序是先遍历左子树再遍历右子树左后遍历根节点,所以后序的最后一个肯定是当前数的根节点,然后从中序中找到根节点,根节点之前的肯定就是当前的树的左子树,根节点之后的就是当前树的右子树,然后分别递归左子树,右子树。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<algorithm>
#include<math.h>
#include<map>
#include<queue>
using namespace std;
int be[1000],mid[1000]; 
struct Node
 {
      int l;
     int r;
 } aa[1000];
 //先从后序遍历中找到根节点,再到中序遍历找到它出现的位置,然后递归下去 
 int build(int la,int ra,int lb,int rb)//la,ra为中序遍历的起点和终点,lb,rb为后序遍历的起点和终点 
 {
    if(la>ra)
        return 0;//防止出界 
    int root,p1,p2;
     root=be[rb];//根节点就是后续遍历的最后一个 
     p1=la;
     while(mid[p1]!=root) p1++;//从中序遍历中找到根节点 
     p2=p1-la;//P2为该根节点的左子数的个数 
     aa[root].l=build(la,p1-1,lb,lb+p2-1);//递归思想 
     aa[root].r=build(p1+1,ra,lb+p2,rb-1);
     return root;
 }
 void bfs(int x) //层次遍历
 {
     queue<int> q;
     vector<int> v;
     q.push(x);
     while(!q.empty())
     {
         int w=q.front();
         q.pop();
         if(w==0)
             break;
         v.push_back(w);
         if(aa[w].l!=0) q.push(aa[w].l);
         if(aa[w].r!=0) q.push(aa[w].r);
     }
     int len=v.size();
     for(int i=0; i<len; i++)
         printf("%d%c",v[i],i==len-1?'
':' ');
     return ;
 }
 
int main()
{	 
     int n;
     scanf("%d",&n);
     for(int i=0; i<n; i++) scanf("%d",&be[i]);
     for(int i=0; i<n; i++) scanf("%d",&mid[i]);
     build(0,n-1,0,n-1);
     int root=be[n-1];
     bfs(root);
	     return 0;
}
原文地址:https://www.cnblogs.com/cmmdc/p/6729717.html