poj 1325(二分图的最小点覆盖)

konig定理 : 最小点覆盖数=最大匹配

要注意的一点是: 一开始A,B都处于0模式,所以所有与0有关的边都不需要考虑了。。

Machine Schedule
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9989   Accepted: 4248

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 
There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 
For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 
Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 
The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
#define    N 210
int n,m,k;
struct node
{
    int to,next;
}edge[2100];

int cnt,pre[N];
int mark[N],frt[N];

void add_edge(int u,int v)
{
    edge[cnt].to=v;
    edge[cnt].next=pre[u];
    pre[u]=cnt++;
}

int dfs(int s)
{
    for(int p=pre[s];p!=-1;p=edge[p].next)
    {
        int v=edge[p].to;
        if(mark[v]==1) continue;
        mark[v]=1;
        if(frt[v]==-1||dfs(frt[v])==1)
        {
            frt[v]=s;
            return 1;
        }
    }
    return 0;
}

int main()
{
    while(scanf("%d",&n)&&n)
    {
        cnt=0;
        memset(pre,-1,sizeof(pre));
        scanf("%d%d",&m,&k);
        for(int i=0;i<k;i++)
        {
            int key,x,y;
            scanf("%d%d%d",&key,&x,&y);
            if(x==0||y==0) continue;
            add_edge(x,y);
        }
        int sum=0;
        memset(frt,-1,sizeof(frt));
        for(int i=0;i<n;i++)
        {
            memset(mark,0,sizeof(mark));
            sum+=dfs(i);
        }
        printf("%d\n",sum);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/chenhuan001/p/3013865.html