拓扑排序(1)

Description

有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。 
 

Input

输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。 
 

Output

给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。 

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。 
 

Sample Input

4 3 1 2 2 3 4 3
 

Sample Output

1 2 4 3
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N=510;
int i,j,k,m,n;
int map[N][N],indegre[N];

void topo()
{
    for(i=1;i<=n;i++)
    for(j=1;j<=n;j++)
    {
        if(indegre[j]==0)
        {
            indegre[j]--;     //输出这个点后,划去这个点
            if(i!=n) cout<<j<<" ";
            else cout<<j<<endl;
            for(k=1;k<=n;k++)     //划去这个人赢的对手之间的线
            {
                if(map[j][k]==1)
                indegre[k]--;
            }
            break;
        }
    }
}

int main()
{
    int p,q;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(map,0,sizeof(map));
        memset(indegre,0,sizeof(indegre));
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&p,&q);
            if(!map[p][q])
            {
                map[p][q]=1;      //q输给的对手个数为indegre[q]
                indegre[q]++;
            }
        }
        topo();
    }
    return 0;
}
原文地址:https://www.cnblogs.com/chen9510/p/4739348.html