Sum Problem hdu 1001

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 488812    Accepted Submission(s): 124145

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 
Sample Input
1 100
 
Sample Output
1 5050
 
Author
DOOM III

 题解:注意原谅绿的那句话!!太坑人了,我一开始打表写的,不是超时就是运行错误,

       仔细揣摩那句话的意思,奥您可以假设结果将在32位有符号整数的范围内!!!

       还能是啥意思?就是可以直接用int呗??

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int a;
    while(~scanf("%d",&a))
    {
        int b=0;
        for(int i=1;i<=a;i++)
           b=b+i;
       printf("%d

",b);
    }
    return 0;
}

今天不是元气满满的一天QAQ

原文地址:https://www.cnblogs.com/cattree/p/7517642.html