PAT 甲级 1071 Speech Patterns (25 分)(map)

                                      1071 Speech Patterns (25 分)

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return  . The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

题意:

给定一个字符串,从中找出重复次数最多的符合要求的单词,输出该单词以及出现次数。组成该单词的字符只能出自[0-9 A-Z  a-z]集合。如果有出现次数相同的单词,则按照单词的字典序,输出第一个单词。

题解:

我还以为有个人名,结果不用管开头的人名。

使用map很方便

AC代码:

#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
#include<map>
using namespace std;
map<string,int>m;
int main(){
	string name,s;
	getline(cin,s);
	int l=s.length();
	string word="";
	for(int i=0;i<l;i++){
		s[i]=tolower(s[i]);
		if(isalnum(s[i])) word+=s[i];
		else{
			if(word!="") {
				if(m.find(word)==m.end()) m[word]=1;
				else m[word]++;
			}
			word="";
		}
	}
	if(word!="") m[word]++;
	string ans;
	int count=0;
	map<string,int>::iterator it;
	for(it=m.begin();it!=m.end();it++){
		if(it->second>count){
			count=it->second;
			ans=it->first;
		}
	}
	cout<<ans<<" "<<count;
	return 0;
}

原文地址:https://www.cnblogs.com/caiyishuai/p/13270609.html