PAT 甲级 1065 A+B and C (64bit) (20 分)(溢出判断)*

1065 A+B and C (64bit) (20 分)
 

Given three integers A, B and C in [−], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题解:

没有这样去考虑,没做对

因为A、B的大小为[-2^63, 2^63],用long long 存储A和B的值,以及他们相加的值sum:
如果A > 0, B < 0 或者 A < 0, B > 0,sum是不可能溢出的
如果A > 0, B > 0,sum可能会溢出,sum范围理应为(0, 2^64 – 2],溢出得到的结果应该是[-2^63, -2]是个负数,所以sum < 0时候说明溢出了

如果A < 0, B < 0,sum可能会溢出,同理,sum溢出后结果是大于0的,所以sum > 0 说明溢出了

AC代码:

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
long long a,b,c,sum;
int main(){
    int n;
    cin>>n;
    for(int i=1;i<=n;i++){
        cin>>a>>b>>c;
        sum=a+b;
        if(a>0&&b>0&&sum<=0){
            cout<<"Case #"<<i<<": "<<"true"<<endl;
        }else if(a<0 &&b<0 &&sum>=0){
            cout<<"Case #"<<i<<": "<<"false"<<endl;
        }else if(sum>c){
            cout<<"Case #"<<i<<": "<<"true"<<endl;
        }else{
            cout<<"Case #"<<i<<": "<<"false"<<endl;
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/caiyishuai/p/11637817.html