大数加法,A+B

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 169591    Accepted Submission(s): 32528


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2 1 2 112233445566778899 998877665544332211
 
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
用字符数组保存大数,模拟手算注意进位处理,以及第一位数是否进位。
 
 

#include<stdio.h>
#include<string.h>
#define N 1001
int main()
{
char str1[N],str2[N];
int t,i = 0;
scanf("%d",&t);
while(t--)
{
i++;
scanf("%s %s",str1,str2);
printf("Case %d: %s + %s = ",i,str1,str2);
int a[N]={0},b[N]={0},k,i;
k = strlen(str1)>strlen(str2)?strlen(str1):strlen(str2);
for(i = 0;i<strlen(str1);i++)
a[i] = str1[strlen(str1)-1-i]-'0';
for(i = 0;i<strlen(str2);i++)
b[i] = str2[strlen(str2)-1-i]-'0';
if(strlen(str1)>strlen(str2))
{
for(i = 0;i<strlen(str1);i++)
{
a[i]+=b[i];
if(a[i]>9)
{
a[i]-=10;
a[i+1]++;
}
}
if(a[k]!=0)
for(i = k;i>=0;i--)
printf("%d",a[i]);
else
for(i = k-1;i>=0;i--)
printf("%d",a[i]);
}
else
{
for(i = 0;i<strlen(str2);i++)
{
b[i]+=a[i];
if(b[i]>9)
{
b[i]-=10;
b[i+1]++;
}
}
if(b[k]!=0)
for(i = k;i>=0;i--)
printf("%d",b[i]);
else
for(i = k-1;i>=0;i--)
printf("%d",b[i]);
}
printf(" ");
if(t)
printf(" ");

}
return 0;
}

原文地址:https://www.cnblogs.com/anhuizhiye/p/3315922.html