【UVa 1593】Alignment of Code

 You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc.

For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input 

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output 

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi.


Note for the Sample:

The `$ sqcup$' character in the example below denotes a space character in the actual files (ASCII code 32).

Sample Input 

  start:  integer;    // begins here
stop: integer; //  ends here  
 s:  string;   
c:   char; // temp

Sample Output 

start: integer; // begins here 
stop:  integer; // ends   here 
s:     string;
c:     char;    // temp

一道简单的模拟题。
找出每列最长的单词就行了。
注意行尾是不带空格的!
#include<cstdio>
#include<cstring>
#include<iostream>
#include<sstream>
#include<string>
#include<algorithm>

using namespace std;

string words[1005][185];
int maxlen[185];
int row;
int col[1005];

void print(string str, int ll)
{
    cout << str;
    for (int i = 0; i < ll - str.length(); ++i) printf(" ");
}

int main()
{
    memset(col, 0, sizeof(col));
    string s;
    row = 0;
    while (getline(cin, s))
    {
        stringstream ss(s);
        while (ss >> words[row][col[row]]) col[row]++;
        ++row;
    }
    for (int i = 0; i < 185; ++i)
    {
        maxlen[i] = 0;
        for (int j = 0; j < row; ++j)
            if (col[j] > i) maxlen[i] = max(maxlen[i], (int)words[j][i].length());
    }
    for (int i = 0; i < row; ++i)
    {
        for (int j = 0; j < col[i] - 1; ++j)
            print(words[i][j], maxlen[j] + 1);
        cout << words[i][col[i] - 1] << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/albert7xie/p/4754720.html