Programming Ability Test学习 1064. Complete Binary Search Tree (30)

1064. Complete Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4

提交代码

注:利用完全二叉树数组的特性,i的左子树是2i,右子树是2i+1

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm> 
#include<map>
#define MAXSIZE 100005
typedef long long ll;

using namespace std;
int current=0;

int cmp(const void *a,const void *b)
{
	return *(int *)a-*(int *)b;
}

//构建完全二叉树
void BuildTree(int point,int *Get,int *Tree,int n)//point当前结点,Get是存放有序数列的数组 
{
	if(point<=n)
	{
	    BuildTree(point<<1,Get,Tree,n);//左子树	
	    Tree[point]=Get[current++];
	    BuildTree((point<<1)+1,Get,Tree,n);//左子树	
	}
} 

int main()
{
	int Get[MAXSIZE];
	int Tree[MAXSIZE];
	int N;
	cin>>N;
	for(int i=0;i<N;i++)cin>>Get[i];
	qsort(Get,N,sizeof(Get[0]),cmp);
    //for(int i=0;i<N;i++)cout<<Get[i]<<" ";
    BuildTree(1,Get,Tree,N); 
    
    for(int i=1;i<N;i++)cout<<Tree[i]<<" ";
    cout<<Tree[N]<<endl;
    
	return 0;
} 

  

原文地址:https://www.cnblogs.com/a842297171/p/4794472.html