pat 甲级 1080. Graduate Admission (30)

1080. Graduate Admission (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8

1 4

 题意:模拟,多所学校依据学生的志愿录取学生,录取规则如下:1:首先分数高的学生优先入选2:同一个人有k个志愿可选,前面的志愿没被录取,才可利用接下来的志愿3:若一所高校需要录取的人数已满,还有人报该所学校,且与该校录取最低分数一样,该学生还是会该学校录取。

AC代码:

#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<set>
#include<queue>
using namespace std;
#define INF 0x3f3f3f
#define N_MAX 40000+5
#define M_MAX 100+5
int n,m,k;//m是学校数量,k是志愿数
int need_num[N_MAX];
struct Student {
    int id;
    double G1, G2;
    int choice[5];
    bool operator < (const Student&b)const {
        if ((G1 + G2) != (b.G1 + b.G2))return  (G1 + G2) > (b.G1 + b.G2) ;
        else return G1 > b.G1;
    }
    bool is_same(const Student&b)const {
       return ((G1 + G2) == (b.G1 + b.G2) )&&( G1 == b.G1);
    }
}stu[N_MAX];
set<int>res[M_MAX];
double last_final[M_MAX], last_G1[M_MAX];//记录每个学校最后一个录取生的成绩情况
int main() {
    while (scanf("%d%d%d", &n, &m, &k) != EOF) {
        memset(need_num,0,sizeof(need_num));
        for (int i = 0; i < m; i++)scanf("%d", &need_num[i]);
        for (int i = 0; i < n; i++) {
            stu[i].id = i;
            scanf("%lf%lf", &stu[i].G1, &stu[i].G2);
            for (int j = 0; j < k; j++)scanf("%d", &stu[i].choice[j]);
        }
        sort(stu, stu + n);
        for (int i = 0; i < n;i++) {//分数高的先选志愿
            for (int j = 0; j < k;j++) {//一共k个志愿
                int cur_sch = stu[i].choice[j];
                if (need_num[cur_sch]) {//当前学校还可以录取人
                    res[cur_sch].insert(stu[i].id);
                    need_num[cur_sch]--;
                    last_final[cur_sch] = stu[i].G1 + stu[i].G2;
                    last_G1[cur_sch] = stu[i].G1;
                    break;
                }
                else if ((stu[i].G1+stu[i].G2)==last_final[cur_sch]&&stu[i].G1==last_G1[cur_sch]) {//分数与之前的人相同
                    res[cur_sch].insert(stu[i].id);
                    break;
                }
            }
        }

        for (int i = 0; i < m;i++) {
            int j = 0;
            for (set<int>::iterator it = res[i].begin(); it != res[i].end();it++,j++) {
                printf("%d%c",*it,j+1==res[i].size()?'
':' ');
            }
            if (res[i].size() == 0)puts("");
        }

    }
    return 0;
}
原文地址:https://www.cnblogs.com/ZefengYao/p/8529933.html