poj 2010 Moo University

                                                                                            Moo University - Financial Aid
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 7961   Accepted: 2321

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 
 
题意:有C头牛想要进大学,但只能从中挑选出N头牛进大学,并且给这N头牛的补助资金总和不能超过F,在满足此条件的情况下,求挑选出来的N头牛中成绩最中间的牛的成绩最高是多少。
思路:可以先将C头牛按成绩从低到高排序,之后遍历每头牛,对于每头牛,挑选出比当前牛成绩低的(N/2)头牛,使得这些牛需要资金的总和达到最小值并记录此最小值,再次遍历求成绩比当前牛成绩高的牛中挑选出来的(N/2)牛需要资金总和的最小值,最后取和与F作比较即可,使得满足条件的那头牛的成绩越高越好。
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<queue>
#include<functional>
using namespace std;
const int N_MAX = 100000+1;
struct cow {
    int score;
    int need_money;
    bool operator<(const cow&b)const{
        return score<b.score ;
    }
};
cow cows[N_MAX];
int lower_money[N_MAX];
int upper_money[N_MAX];
int main() {
    //cout << 0x3f3f3f3f <<" "<<INT_MAX<<endl;
    int N, C, F;
    scanf("%d%d%d",&N,&C,&F);
    for (int i = 0;i < C;i++) 
        scanf("%d%d",&cows[i].score,&cows[i].need_money);
    sort(cows,cows+C);//按成绩从低到高排
    priority_queue<int>que;
    unsigned int half = N / 2,total=0;
    for (int i = 0;i < C;i++) {//对于每一头牛,计算成绩比他低的牛的资金总和的最小值
        lower_money[i] = ( que.size() == half ? total : 0x3f3f3f3f);
        que.push(cows[i].need_money);
        total += cows[i].need_money;
        if (que.size() > half) {
            total -= que.top();
            que.pop();
        }
    }
    
    priority_queue<int>q;
    total = 0;
    for (int i = C - 1;i >= 0;i--) {
        upper_money[i] = (q.size() == half ? total : 0x3f3f3f3f);
        q.push(cows[i].need_money);
        total += cows[i].need_money;
        if (q.size() > half) {
            total -= q.top();
            q.pop();
        }
    }
    int grade=-1;
    for (int i = C-1;i>=0;i--) {
        if (upper_money[i] + lower_money[i] + cows[i].need_money <= F) { grade = cows[i].score; break; }
    }
    if (grade>0)cout << grade << endl;
    else cout << grade << endl;
    return 0;
}
 
原文地址:https://www.cnblogs.com/ZefengYao/p/5902468.html