401 Palindromes

  Palindromes 

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y" are all their own reverses.


A list of all valid characters and their reverses is as follows.


Character Reverse Character Reverse Character Reverse
A A M M Y Y
B   N   Z 5
C   O O 1 1
D   P   2 S
E 3 Q   3 E
F   R   4  
G   S 2 5 Z
H H T T 6  
I I U U 7  
J L V V 8 8
K   W W 9  
L J X X    


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.


STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.

 题目很简单,判断回文和镜像,镜像表题目已经给出,需要注意的是在从前边扫描和从后边扫描的时候记得判断最中间那个字符

即:        for(i = 0 ; i <= mid ; ++i)  ,是<=号,而不是<号,因为判断镜像字符的时候可能会出错,下面是代码

#include <iostream>
#include <string>
#include <cstring>
using namespace std;
char ch_table[] = "AEHIJLMOSTUVWXYZ12358";
char re_table[] = "A3HILJMO2TUVWXY51SEZ8";
char out_put[][50] = {
" -- is not a palindrome.",
" -- is a regular palindrome.",
" -- is a mirrored string.",
" -- is a mirrored palindrome."
};
char table[128];//字符判定表
int main()
{

    int len = strlen(ch_table);
    int i , mid;
    char str[21];
    bool is_palindrome , is_mirrored;
    for(i = 0 ; i < len ; i ++)  table[ch_table[i]] = re_table[i];//初始化
    while(cin>>str)
    {
        is_palindrome = true;
        is_mirrored = true;
        len = strlen(str);
        mid = len>>1;
        for(i = 0 ; i <= mid ; ++i)
        {
            if(str[i] != str[len-1-i]) is_palindrome =false;
            if(table[str[i]] && table[str[len-1-i]] == str[i]);
            else is_mirrored = false;
        }
        cout<<str<<out_put[is_palindrome + 2*is_mirrored]<<endl;//利用位运算的方法,直接输出
        cout<<endl;//多输出一个换行
    }
    return 0;
}
原文地址:https://www.cnblogs.com/UnGeek/p/2551048.html