PAT1028—— 人口普查

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

重载运算符就够了哇。不需要用set,vector,用了反而出错,就是取最大最小值!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <cstdlib>
#include<cmath>
#include <string>
#include <map>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <cctype>
using namespace std;
typedef unsigned long long ull;
#define INF 0xfffffff

struct people{
    string name;
    int year,month,day;
    bool operator < (const people &p) const
    {
        if(year==p.year)
        {
            if(month==p.month)
            {
                return day<p.day;
            }
            return month<p.month;
        }
        return year<p.year;
    }
};

int valid(people p)
{
    int ok=1;
    if(p.month<1||p.month>12||p.day<1||p.day>31)
        ok=0;
    if(p.year<1814||p.year>2014)
        ok=0;
    else if(p.year==1814&&p.month<9)
        ok=0;
    else if(p.year==1814&&p.month==9&&p.day<6)
        ok=0;
    else if(p.year==2014&&p.month>9)
        ok=0;
    else if(p.year==2014&&p.month==9&&p.day>6)
        ok=0;
    return ok;
}

int main()
{ 
    int n,x,y,i,j,k;
    people p,p1,p2;
    cin>>n;
    x=0;
    for(i=0;i<n;++i)
    {
        cin>>p.name;
        scanf("%d/%d/%d",&p.year,&p.month,&p.day);
        if(valid(p))
        {
            ++x;
            if(i==0)
            {
                p1=p2=p;
            }
            if(p<p1)
                p1=p;
            if(p2<p)
                p2=p;
        }
    }
    if(x!=0)
    {
        cout<<x<<" "<<p1.name<<" "<<p2.name<<endl;
    }
    else
    {
        printf("0");
    }
    
    return 0;
}
原文地址:https://www.cnblogs.com/Traveller-Leon/p/4972148.html