C

C - Wooden Sticks
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2). 
 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces. 
 

Output

The output should contain the minimum setup time in minutes, one per line. 
 

Sample Input

3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output

2 1 3
这一题是学姐给的思路。就是先按照长度排序,然后再用flag记录是否访问过。
#include<iostream>
#include<algorithm>
using namespace std;
typedef struct dot{
    int l,w;
    bool flag;
}dot;
bool cmp(dot a,dot b)
{
    if(a.l!=a.l)return a.w<a.w;
    else  return a.l<b.l;
}
int main()
{
    int T,n;
    cin>>T;
    while(T--)
    {
        cin>>n;
        dot a[10000];
        for(int i=0;i!=n;i++){
            cin>>a[i].l>>a[i].w;
            a[i].flag=0;
        }
        sort(a,a+n,cmp);
        int sum=0;
        for(int i=0;i!=n;i++){
            if(a[i].flag==0){
                sum++;
                a[i].flag=1;
                int k=i;
                for(int j=k;j!=n;j++){
                    if(!a[j].flag&&a[k].w<=a[j].w){k=j;a[j].flag=1;}
                }
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}

贪心练得不好。。。。
原文地址:https://www.cnblogs.com/NYNU-ACM/p/4248804.html