PTA(Basic Level)1006.Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
思路
代码
#include<bits/stdc++.h>
using namespace std;
struct node
{
	char name[20];
	int hh,mm,ss;
}small, big;

void Init()
{
	big.hh = big.mm = big.ss = 0;
	small.hh = 24;
	small.mm = small.ss = 59;
}

bool early(node a, node b)
{ //true-a的时间早于b的时间
	if(a.hh != b.hh)	return a.hh <= b.hh;
	else if(a.mm != b.mm)	return a.mm <= b.mm;
	else return a.ss <= b.ss;
}
int main()
{
	int m;
	cin >> m;
	Init();

	node tmp;
	while(m--)
	{
		scanf("%s %d:%d:%d", &tmp.name, &tmp.hh, &tmp.mm, &tmp.ss);
		if(early(tmp, small))
			small = tmp; //更新最早
		scanf("%d:%d:%d", &tmp.hh, &tmp.mm, &tmp.ss);
		if(early(big, tmp))
			big = tmp;  //更新最晚
	}
	cout << small.name << " " << big.name;
	return 0;
}


引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805516654460928

原文地址:https://www.cnblogs.com/MartinLwx/p/11664525.html