Hdoj 2602.Bone Collector 题解

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
img

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

Author

Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest


思路

简单的01背包问题。

因为不用恰好装满,所以初始化的时候(f[i])全都初始化为0

代码

#include<bits/stdc++.h>
using namespace std;
int value[1001];
int cost[1001];
int f[1001];
int main()
{
	int T;
	cin >> T;
	while(T--)
	{
		int n,v;
		cin >> n >> v;
		memset(f,0,sizeof(f));
		for(int i=1;i<=n;i++)	cin >> value[i];//价值
		for(int i=1;i<=n;i++)	cin >> cost[i];//花费
		for(int i=1;i<=n;i++)
			for(int j=v;j>=cost[i];j--)
				f[j] = max(f[j], f[j-cost[i]]+value[i]);
		cout << f[v] << endl;
	}
	return 0;
}
原文地址:https://www.cnblogs.com/MartinLwx/p/10005678.html