2016HUAS暑假集训训练题 G

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
18
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
 

Sample Output

0
1
2
2
 
分析:
本题为一个dfs题  寻找图中有几块油田  首先依次寻找 找到的标记下  再寻找下一个直到再也找不到为止题较为简单直接贴AC代码:
#include <iostream>
#include <cstring>
using namespace std;
char a[100][100];
int x,i,j,y;
int t[100][100];

void bfs(int o,int p, int num)  //定义bfs函数
{
    if(o<0||o>=x||p>=y||p<0) return;  //过界就退出
    if(a[o][p]!='@'||t[o][p]!=0) return; //  没有找到或者已经找到过的也退出
      t[o][p] = num;
     for(int i = -1;i <=1;i++)
     {
         for(int j = -1;j <= 1;j++)
        {
          if(i != 0||j != 0)
            {
                bfs(o+i,p+j,num);          //继续寻找下个
            }
        }
     }
}
int main()
{
    int s ;
    while(cin>>x>>y)
    {
        if(x == 0  && y == 0) break;
         memset(t,0,sizeof(t));
        for( i = 0; i < x;i++)
        {
            for(  j = 0; j < y; j++)
            {
              cin>>a[i][j];
            }
        }
          s = 0;
        for(i = 0; i < x; i++)
            for(j = 0; j < y; j++)
            {
             if(t[i][j]==0&&a[i][j]=='@') bfs(i,j,++s); //没有找到过的且是油田 就进入dfs寻找
            }
        cout<<s<<endl;
    }
    return 0;
}
 
原文地址:https://www.cnblogs.com/LIUWEI123/p/5676825.html