HDU 1124

Factorial

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5414 Accepted Submission(s): 3503

Problem Description

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.
ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called “Travelling Salesman Problem” and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4…N. The number is very high even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1<N2, then Z(N1) <= Z(N2). It is because we can never “lose” any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.

Input

There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output

For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input

6
3
60
100
1024
23456
8735373

Sample Output

0
14
24
253
5861
2183837

题目链接
题目大意:输入t,之后有 t 行,求第 i 个数阶乘后面0的数量。

解题思路:通过观察可以发现:想要在阶乘后面出现0,必须通过2 x 5 来实现,所以我们要统计2和5的数量。我们还可以发现在这些数中,2的数量是一定比5的数量多的,所以我们只需要统计5的数量就好了。即每个数贡献了几个5,如25=5 · 5,则25贡献了两个5,以25为例:n是5的倍数的数有1 5 10 15 20 25,是25的倍数的有25,最后我们将这些数相加即可,所以最后是6。一个数/5,就可以知道在 1-n 中是 5 的倍数的数有几个,/25 就可以知道25的倍数的数有几个。以此类推。AC代码:

#include <cstdio>
#include <iostream>
using namespace std;
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int cnt=0,n;
		cin>>n;
		while(n)
		{
			cnt+=n/5;//统计5 25 125 ... 的倍数的数
			n/=5;
		}
		cout<<cnt<<endl;
	}
	//system("pause");
	return 0;
}
原文地址:https://www.cnblogs.com/Hayasaka/p/14294284.html