HDU 2035 人见人爱A^B

人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17396    Accepted Submission(s): 12325


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 
Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 
Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 
Sample Input
2 3
12 6
6789 10000
0 0
 
Sample Output
8
984 
1
 
Author
lcy
 
Source
 
Recommend
lcy
 
 
思路:水
 
代码;
#include <iostream>
using namespace std;
int main()
{
    int m,n;
    int a;
    while ( cin>>m>>n&&!( m==0&&n==0 ) )
    {
        a = m;

        for ( int i=1;i<n;++i )
        {
             if ( a * m>1000 )
                a =(a * m)%1000;
             else
                 a *= m;
        }
        cout<<a<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/GODLIKEING/p/3360400.html