HDU 1728 逃离迷宫

逃离迷宫

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 21   Accepted Submission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input

  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,   第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。

Output

  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input

2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3

Sample Output

no
yes

Source

“网新恩普杯”杭州电子科技大学程序设计邀请赛
 
思路:BFS
 
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int
biji[110][110];
char
map[110][110];
struct
Node
{

    int
x,y;
};

int
bfs[4][2]  = {1,0,-1,0,0,1,0,-1};
int
t,m,n;
int
k,ay,ax,by,bx;
int
BFS()
{

    queue <Node> q;
    memset(biji,-1,sizeof(biji));
    Node top;
    top.x = ax;top.y = ay;
    q.push(top);
    while
(!q.empty())
    {

        Node temp;
        int
k_used;
        temp = q.front();
        q.pop();
        k_used = biji[temp.x][temp.y] + 1;
        if
(k_used > k)
             break
;
        for
(int i = 0;i < 4;i ++)
        {

            int
x = temp.x + bfs[i][0];int y = temp.y + bfs[i][1];
            while
(x <= m && x >= 1 && y <= n && y >= 1 && map[x][y] == '.')
            {

                if
(biji[x][y] == -1)
                {

                    if
(x == bx && y == by && k_used <= k)
                         return
true;
                    else

                    {

                        Node xin;xin.x = x;xin.y = y;
                        q.push(xin);
                        biji[x][y] = k_used;
                    }
                }

                x += bfs[i][0];y += bfs[i][1];
            }
        }
    }

    return
false;
}

int
main()
{

    scanf("%d",&t);
    while
(t --)
    {

        scanf("%d%d",&m,&n);
        for
(int i = 1;i <= m;i ++)
           for
(int j = 1;j <= n;j ++)
              scanf(" %c",&map[i][j]);
        scanf("%d%d%d%d%d",&k,&ay,&ax,&by,&bx);
        //printf("%d %d %d %d %d ",k,ay,ax,by,bx);
        if(BFS())
            printf("yes ");
        else

            printf("no ");
    }
}

        
   
原文地址:https://www.cnblogs.com/GODLIKEING/p/3283588.html