PAT 1007 素数对猜想(20)

1007 素数对猜想(20 分)

让我们定义d​n​​为:d​n​​=p​n+1​​−p​n​​,其中p​i​​是第i个素数。显然有d​1​​=1,且对于n>1有d​n​​是偶数。“素数对猜想”认为“存在无穷多对相邻且差为2的素数”。

现给定任意正整数N(<10​5​​),请计算不超过N的满足猜想的素数对的个数。

输入格式:

输入在一行给出正整数N

输出格式:

在一行中输出不超过N的满足猜想的素数对的个数。

输入样例:

20

输出样例:

4
#include<iostream>
#include<string>
#include<cmath>
using namespace std;
#define max 100000
int a[max];
int is(int i) {   //判断素数
	for (int j = 2; j <= sqrt(i); j++)
		if (i%j == 0)
			return 0;
	return 1;
}
int main() {
	int count = 0;
	int n;
	cin >> n;
	for (int i = 2; i <= n; i++) {
		if (is(i))
			a[i] = 1;
	}
	for (int i = 1; i <= n; i++) {
		if (a[i] && a[i + 2])
			count++;
	}
	cout << count;
	return 0;
}
原文地址:https://www.cnblogs.com/F-itachi/p/9974400.html