HDU 1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 199099    Accepted Submission(s): 38099


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2 1 2 112233445566778899 998877665544332211
 
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
 

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int sum[111111];
int main()
{
int t,j=0;
int i,lenmax=0,lenmin=0,jw=0,xh=0,a=0;
cin>>t;
for(j=0; j<t; j++)
{
string s1,s2,c1,c2;
memset(sum,0,sizeof(sum));
cin>>s1>>s2;
c1=s1,c2=s2;
if(s1.size()<s2.size())swap(s1,s2);
lenmax = s1.size()-1;
lenmin = s2.size()-1;
jw = lenmax;
xh = lenmin;
for(i=0; i<xh+1; i++)
{
sum[i] = s1[lenmax--]+s2[lenmin--]-'0'-'0';
}
for(int pp = i;pp < jw+1;pp ++) sum[pp] = s1[lenmax--]-'0';
for(i=0 ; i<=jw ; i++)
{
if(sum[i]>9)
{
if(i==jw)a++;
sum[i]=sum[i]-10;
sum[i+1]++;
}
}
cout<<"Case "<<j+1<< ":" << endl;
cout<<c1<<" + "<<c2<<" = ";
for(i = jw+a; i>=0; i--)
{
cout<<sum[i];
}
cout<<endl;
i=0;lenmax = 0;lenmin = 0;jw = 0;a = 0;xh = 0;
if(j < t-1)puts("");
}
return 0;
}

原文地址:https://www.cnblogs.com/Duskcl/p/3700379.html