[PAT 甲级] 1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
​​ minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry

思路

利用优先队列,先第一次把所有的队排满,然后出去一个人,就叫一个人
需要注意的坑点就是,只要能在16:59之前开始接受服务就行WA了一上午,太惨了

#include<bits/stdc++.h>
using namespace std;

int  w[21];
int cost[1005];
int query[1005];

string trans(pair<int,int> i){
	int h = i.first/60+8;
	int m = i.first%60;
	if(i.second+480>=1020)
		return "Sorry";
	string ans = "";
	if (h<10)
		ans = "0"+to_string(h)+":";
	else
		ans = to_string(h)+":";
	if (m<10)
		ans += "0"+to_string(m);
	else
		ans += to_string(m);
	return ans;
}
struct Cmp
{
	bool operator()(const pair<pair<int,int>,pair<int,int>>&a,pair<pair<int,int>,pair<int,int>>&b){

		return a.second.first==b.second.first?a.first.second>b.first.second:a.second.first>b.second.first;
	}
	
};
int main(int argc, char const *argv[])
{
	priority_queue<pair<pair<int,int>,pair<int,int>>,vector<pair<pair<int,int>,pair<int,int>>>,Cmp> q; 
	map<int,pair<int, int>> mp;
	int a,b,c,d;
	cin>>a>>b>>c>>d;
	for (int i = 0; i < c; ++i)
		cin>>cost[i];
	for (int i = 0; i < d; ++i)
		cin>>query[i];
	int beg;
	for(int i=0; (i<(a*b))&&(i<c); i++){
		beg = w[i%a];
		w[i%a] += cost[i];//更新等待时间
		q.push(make_pair(make_pair(i,i%a),make_pair(beg+cost[i],beg))); //入队
	}
	pair<pair<int,int>,pair<int,int>> temp;
	int cid = a*b;
	while(!q.empty()){
		temp = q.top();
		q.pop();
		mp[temp.first.first] = temp.second; //记录时间
		if(cid<c){
			//有个b要去排队
			beg = w[temp.first.second];//获取前面一个人的等待的时间
			w[temp.first.second] += cost[cid];//更新等待时间
			q.push(make_pair(make_pair(cid,temp.first.second),make_pair(beg+cost[cid],beg))); //入队
		}
		cid++;
	}
	for (int i = 0; i < d-1; ++i)
		cout<<trans(mp[query[i]-1])<<endl;
	if (d>0)
		cout<<trans(mp[query[d-1]-1]);
	return 0;
}
原文地址:https://www.cnblogs.com/Crossea/p/12626162.html